×

Error

Category not found

Compatibility

Joomla! 3.x fully support

JSN Epic 2 is highly compatible with Joomla! 3.6+.

Joomla 3.6+ is recommended for security and performance.

Docs

Full details about template features can be found in a comprehensive documentation package available here.

Read online